Thursday, December 13, 2012

[CentOS] Dependencies problem during DraftSight installation

libaudio.so.2 download for other distribution: http://pkgs.org/download/libaudio.so.2

Installing DraftSight in CentOS 6 with the binary package from official website may give error: 
requires libaudio.so.2
and I cannot find any useful solution from online. So how can we fix this?

It actually not hard to get it done:
  1. Go to http://pkgs.org/centos-6-rhel-6/epel-i386/nas-1.9.1-7.el6.i686.rpm/download/
  2. Download the binary package, install it with Package Manager. This should contain the libaudio.so.2
  3. Run the DraftSight.rpm again
  4. The setup will ask you to install extra stuff before it continues. Click install. Wait until it done.
  5. Once it is  done, navigate to Applications > Graphics.  Voila! DraftSight is running perfectly!

No comments:

Post a Comment